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Chapter 1

/ntroduction

This tutorial provides comprehensive informatiomtthwill help you understand how to create a
FPGA design and run it on you DE2-115 developmerard. The following sections provide a

quick overview of the design flow, explain what yoeed to get started, and describe what you will
learn.

1.1 Design Flow

Figure 1-1shows the FPGA design flow block diagram.

The standard FPGA design flow starts with desigrnyarsing schematics or a hardware description
language (HDL), such as Verilog HDL or VHDL. In $tstep, you can create a digital circuit that is
implemented inside the FPGA. The flow then proceddough compilation, simulation,
programming, and verification in the FPGA hardware.

|

Design ——» Complle ———» Simulate ——» Program - Hardware

Figure 1-1 Design Flow

This tutorial guides you through all of the stegsept for simulation. Although it is not covered in
this document, simulation is very important to feaand there are entire applications devoted to
simulating hardware designs. There are two typesnofilation, Functional and Timing Functional
simulation allows you to verify that your code ismipulating the inputs and outputs appropriately.
Timing (or post place-and-route) simulation vesfithat the design meets timing and functions
appropriately in the device.

Ierm www.terasic.com

wwwwwwwwwwwwww




maslc

1.2 Before You Begin

This tutorial assumes the following prerequisites

B You generally know what a FPGA is. This tutorizled not explain the basic concepts of
programmable logic.

B You are somewhat familiar with digital circuit dgs and electronic design automation (EDA)
tools.

B You have installed the Altera Quartus Il 9.1 spfvgare on your computer. If you do not have
the Quartus Il software, you can download it frdva Altera web site at www.altera.com/download.

B You have a DE2-115 Development Board on which yall test your project. Using a
development board helps you to verify whether yaesign is really working.

B You have gone through the quick start guide antllergetting started user guide for your
development kit. These documents ensure that yee: ha

* Installed the required software.
» Determined that the development board functionpgnly and is connected
to your computer.

Next step you should installed the USB-Blaster eltilug in the 12-volt adapter to provide power
to the board. Use the USB cable to connect thenteft USB connector (the one closest to the
power switch) on the DE2-115 board to a USB pora@omputer that runs the Quartus Il software.
Turn on the power switch on the DE2-115 board.

The computer will recognize the new hardware cotateto its USB port, but it will be unable to
proceed if it does not have the required drivesady installed. The DE2-115 board is programmed
by using Altera USB-Blaster mechanism. If the USRgger driver is not already installed, the New
Hardware Wizard irrigure 1-2 will appear.
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Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard

‘Windows will zearch for current and updated software by
looking on your computer, on the hardware installation CO, or on
the "Windows Update “Web site [with your permission].

Eead our privacy policy

Can Windows connect to "Windows Update to search for
software?

() Yes, this time only
() Yes. now and every time | connect a device
(#) Mo, not this time

Click Mest to continue.

Mext » ][ Cancel

Figure 1-2 Found New Hardware Wizard

Since the desired driver is not available on thaddiws Update Web site, select “No, not this time”
in response to the question asked and click Néus& [Eads to the window iRigure 1-3.

Found New Hardware Wizard

Thes waizard helps you nstall softwase for:

Altera USB-Blaster

.',) If your hardware came with an installation CD
“27 or lloppy disk, insert it now.

What do you want the wizard to do?

() Install the software automatically (Recommended)
(=) Install from a list or specific location [Advanced)

Chck, Mest to cortinue.

< Back ][ Mest » ][ Cancel i

Figure 1-3 The driver is found in a specific location

The driver is available within the Quartus Il sodine. Hence, select Install from a specific location
and click Next to get téigure 1-4.
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Found Mew Hardware Wizard
Please choose your search and installation options.
N &

(%) Search for the best driver in these locations.

Uze the check boxes below to limit or expand the default search, which includes local
paths and removable media. The best driver found will be installed.

Search removable media (floppy. CD-ROM...)
Include this location in the search:

‘C:\altera\g1'\qualtus\drivers\usb-blast91\x32 v! [ Browse ]

() Don't search. | will choose the driver ta install.

Choose thiz option to select the device driver from a list. *windows does not guarantee that
the driver you choose will be the best match for your hardware.

< Back ][ MNext > ][ Cancel

Figure 1-4 Specify the location of the driver

Now, choose Search for the best driver in thesatimes and click Browse to get to the pop-up box
in Figure 1-5 Find the desired driver, which is at location @eva\91\quartus\drivers\usb-blaster.
Click OK and then upon returning teigure 1-4 click Next. At this point the installation will
commence, but a dialog box fiingure 1-6 will appear indicating that the driver has notgekthe
Windows Logo testing. Click Continue Anyway.

Browse For Folder

Select the Folder that contains drivers For wour hardware.,

=[5 quartus ad
I3 bin
IC3) bing4
I3 common
[£3) cusp
= [3) drivers
1) 386
[ sentinel
= [5) usb-blaster
I %3z
=) =64 o

To view any subfolders, click a plus sign above.

[ Ok, l ’ Cancel

Figure 1-5 Browse to find the location
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Hardware Installation

| ': The software you are instaling for this hardveare:
L3
Alera USBE-Blaster

.
has not passed wﬁiﬁs Logo testing to veiily its compatibiiy
with Windows P i i i tant )

Continuing your installation of thiz software may impair
or destabilize the comect operation of pour system
either immediately or in the future. Microzoft strongly
recommends that you stop this inztallation now and
contact the hardware vendor for software that has
passed Windows Logo testing.

| Continue Angway | | STOP Instalistion |

Figure 1-6 There is no need to test the driver

The driver will now be installed as indicatedrgure 1-7 Click Finish and you can start using the
DE2-115 board.

Found New Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard has finished instaling the software for:

Q Altera LISE -Blaster

Click, Finish to close the wizard

Figure 1-7 The driver is installed

1.3 What You Will Learn

In this tutorial you will perform the following t&s:

Create a design that causes LEDs on the develodmand to blink at a speed that is controlled by
an input key—This design is easy to create andsgye@ visual feedback that the design works. Of

5
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course, you can use your DE2-115 board to run atesigns as well. For the LED design, you will

write Verilog HDL code for a simple 32-bit countedd a phase-locked loop (PLL) megafunction
as the clock source, and add a 2-input multiplexegafunction. When the design is running on the
board, you can press an input switch to multiphexd¢ounter bits that drive the output LEDs.

Becoming familiar with Quartus Il design tools—T tigorial will not make you an expert (Please
reference DE2-115 tut_quartus_intro_verilog docuipdiut at the end, you will understand basic
concepts about Quartus Il projects, such as egteridesign using a schematic editor and HDL,
compiling your design, and downloading it into #fGA on your DE2-115 development board.

Develop a foundation to learn more about FPGAs—é@mple, you can create and download
digital signal processing (DSP) functions onto ragka chip, or build a multi-processor system, or
create anything else you can imagine all on theeselnip. You don’'t have to scour data books to
find the perfect logic device or create your ownl@SAIll you need is your computer, your
imagination, and an Altera DE2-115 FPGA developnieatrd.
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Chapter 2

Assign The Device

You begin this tutorial by creating a new Quartuprbject. A project is a set of files that maimtai
information about your FPGA design. The QuartuSdttings File (.qsf) and Quartus Il Project File
(.qpf) files are the primary files in a Quartus dioject. To compile a design or make pin
assignments, you must first create a project.

2.1 Assign The Device

1. Inthe Quartus Il software, select File > New Pcojizard. The Introduction page opens. See
Figure 2-1

Hew Project Wizard: Introduction

The New Project Wizard helps you create a new project and preliminany project settings, including the

following:

* Project name and directony

* MName of the top-level desian entity
- Project files and libraries

: Taiget device family and device

EDA tool settings

Yiou can chanae the settings for an existing proect and specify additional prolect-wide settings with
the Settings command [Assignments menul You can use the vanous pages of the Settings dialog box
to add funchionality to the project

I~ [Don show me thiz introduction agair|

[ wext > ] | iy |

Figure 2-1 New Project Wizard introduction
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2. Click Next.

3. Enter the following information about your prcije

a. What is the working directory for this proje&fter a directory in which you will store your
Quartus Il project files for this design.

b. For example, E:\My_design\my_first_fpga.
c. File names, project names, and directoriesarthartus Il software cannot contain spaces.
d. What is the name of this project? Type my_fiisga.

e. What is the name of the top-level design ertitythis project? Type my_first fpga. See
Figure 2-2.

Hew Project Wizard: Directory, Hame, Top-Lewvel Entity [pag...

‘What is the working directory for this project?

|E:'\My_designkmy_ﬁrsl_fpga
what iz the name of thiz project?
[my_first_foga

‘What is the name of the topJevel design entity for this project? This name is case sensitive and miust
exactly match the entity n{:ge in the design file.

[my_frsl_fpga (=

Use Existing Project Settings ... |

< Back I Hext > I Finish | WiH |

Figure 2-2 Project information

f.  Click Next.

g. You will assign a specific FPGA device to thesiga and make pin assignments. Segire
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Hew Project Wizard: Family & Dewice Settingz [page 3 of 5l [5_(|

Select the family and device you want to target for compilation.

Device family Show in ‘Avalable device' list
Family: | Cyclone Iy E j Package: Ay bl
| J Fin count: Ay -
Target device Speed grade: | Any bl
" Auto device zelected by the Fitter v Show advanced devices
f* Specific device selected in Yvailable devices' list I

Ayailable devices:

M ame Corew.. | LEs Userl/... | Memar... | Embed... | PLL -~
EP4CET15F23CEL 1.0 114480 251 g 532 4
EP4CET15F23C9L 1.0 14480 281 39NNz sz 4
EP4CET15F237 1.2 14480 281 9NNz B3z 4
EP4CET15F2315L 1.0 114450 251 3|2 532 4
EP4CET115F23CT 1.2 i 3331312 : 4
EP4CET115F29CH 1.2 114480 529 39NNz sz 4
EP4CET15F239C8L 1.0 114480 529 9NNz B3z 4 —
FRACF11RF2aral 1 114470 F79 Ei K1V ILCY) 4 ¥
£ | >
o
<Back [ Wext > | Finish | |
Figure 2-3 Specify the Device Example
h.  Click Finish.

4. When prompted, choose Yes to create the my fijoga project directory. You just created
your first Quartus Il FPGA project. Séegure 2-4.
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Quartus II — E:/Ny de=zign/my firszt fpga review/my first fpzga — my first fpga
File Edit ¥iew [Froject Assigmments Processing Tools Hindew Help

DEEHE | S| L BER| o |[mmstmsa =
Hs@EQ T o k|00 (ae
Project MNavigator . X
Entity
Cyclone I¥ E: EF4CE115F29CT |

— my_first_fpgza $E|

_Hierarch_l,l'_l Files'! & Desian Units
Tasks

Flow: |Compilation

AINERAY

13
»

4

Tazk[

= Compile Design

| i

= Analysiz & Synthesis
-~ ] Edit Settings
BB View Report

— hnalysis & Elaboration.
[~ B Partition Merze

QUARTUS 11

ers

| B
*| Type |HESE|agE
o |l ST o ) ]
% System [1] 4 Processing i Estralnfo }\ Irf ?\ ‘Waming J, Crtical'Wamning & Eror i Suppressed  Flag [
E!Message:'l of 1 il il I|_._-.g_;,&'r|.;r,, ;‘ |Lnizate |
For Help, pre=s= Fl | | E= | Idle |_[NTUM_|_ ,fﬂ
Figure 2-4 my_first_fpga project
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Chapter 3

Design Entry

3.1 Add a PLL Megafunction

This section describes How to Add a PLL Megafunctio

In the design entry step you create a schematBlack Design File (.bdf) that is the top-level
design. You will add library of parameterized mau(LPM) functions and use Verilog HDL code

to add a logic block. When creating your own desjgmou can choose any of these methods or a
combination of them.

1. Choose File > New > Block Diagram/Schematic KdeeFigure 3-1 to create a new file,
Block1.bdf, which you will save as the top-levebug.

New &'

SOPC Buider System s
Deszign Files
AHDL File
Block DiagramSchernatic File
EDIF File
State Machine File
Syztemverilog HDL File
Tl Scrpt File
Werlog HDL File
YHOL File
t emony Files
Hexadecimal [Intel-Format] File
b ermory Initialization File
Werification/Debugging Files
In-Sypetem Sources and Probes File
Logic Analyzer Interface File
SignalT ap Il Logic Analyzer File
Wector "W aveform File
Other Files
AHDL Include File
Block Symbal File
Chain Description File
Synopays Design Constraints File
Teut File

ak | Cancel

Figure 3-1 New BDF

11
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2. Click OK.
3. Choose File > Save As and enter the followirigrmation.

* File name: my_first_fpga

» Save as type: Block Diagram/Schematic File (*.bdf)
4. Click Save. The new design file appears in tleeBEditor (see-igure 3-2).

& Quartus IT — E:/Hy_design/my first fpgafmy first fpga — my first fpga —

@Eile Edit Wiew Froject Assigmments PFrocessing Tools Windew Help

- [=]B]X]

DELd & .
BX =J®@® e Iu\-?'p...&' hﬁ;{b

o I my_first_fpoa

-

RSl

@ ® e

.F‘rolject.l\.lawgaﬁ:nr R 4 @ my._first_fpga_bdf ]
Entity B =
CYclﬂnEI‘-"EiEHCE“--- @ e A e P e e P P e e P e e e e e g
o :.my_firgt_fpgaEE | - e Rk e PR i R e R R P b e R R e A e R e SR R R R
[%Pt:D' R iR e PR e SR TR R R e R e R PR e R e e R e R R R e
! Ol M oo
i] ﬁ.li_-—l 0 451 5 P e A0 e P AR P e e e A FR e
s e |
Fl‘:""":l':ﬂml?'il&*-iﬂn = e A e PR e i W e R P e G e e e i e e i R e e i
Task[d - R R PR e SR TR R R PR R e R PR e R e e R e R R R e
=l B Compile Design e e e e e e e P e e e A PR e
2P hnalysis & Sym R EEE e R R
E :---_-f:!E_dith_t_ti__x_ e R 45 R0 PR3P A 83 A0k P R PR
> ------ BB View Reporisw B BRI is R e s FR e PR R e P R e e PR R e R R R PR R R
.<_ } ( ............................................ }
Xl Tape |1~£essage
h;.;. _5.5._lsh=.-m_fn';I Processing ;fn.l Eutra Info J.‘I'-.I_Infn ;"‘. “warning r}". Critical “arning .;"'. Errar r}". Supprezsed ;I'-.IFIag r‘{

5 |Message: e | & | |Location
5 ovee | ]

For Help, press Fl

Idle

[ Bww |

Figure 3-2 Bank BDF

5.
6.
7.

Add HDL code to the blank block diagram by chingd=ile > New > Verilog HDL File.
Click OK to create a new file Verilogl.v, whigbu will save as simple_counter.v.
Select File > Save As and enter the followirfgrimation (seé-igure 3-3).

File name: simple_counter.v
Save as type: Verilog HDL File (*.v, *.vlg, *.vead)

12
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Bh

£
HRAATIR

Fr—1
B

£H
ﬁéEr_ﬂI%

i
%Eﬁ?ﬂ*

.

Fi_E=BRE

=

{RIFIE 1) ] ) my_first_fpga j dm ﬁ v

=hdb

I
{RiFIed (1)

zirn le counter.w Tj

]Verilu:-g HOL File Ok w;d wlg;®, veril-:-g_:_j

v Add file to current project

Figure 3-3 Saving the Verilog HDL file

The resulting empty file is ready for you to eritex Verilog HDL code.

| {®iF E) |
HLiH

8. Type the following Verilog HDL code into the hlasimple_counter.v file (seegure 3-4 The
Verilog File of simple_counter.v).

/it has a single clock input and a 32-bit outpoittp

module simple_counter (

input CLOCK 50;

wwwwwwwwwwwwww

CLOCK_50,

counter_out

13
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output [31:0] counter_out;

reg [31:0] counter_out;
always @ (posedge CLOCK_50) // osifpee clock edge
begin

counter_out <= #1 counter_out + 1;// increment ¢eun

end

endmodule /I ednodule counter

¥ Quartus IT — E: /Ny desizn/my first fpga/my first fpga — my first fpza — [simple counter. vl

5@3 File Edit Yiew FProject Assigoments Frocessing Tools Windew Help -
W ﬁ = _ K7 |m:;_ﬂrst_T|.'uga __:J
@S D rwn vh k&0 4 @

Praject Mavigator - X {&*c R e ]

3 Files i
i my first fpza Bd Y
< > —
— = az

? ok

Tasks - X :

Flow: 1Compilation - =

Task[ -~

A%
=] r Compile Desi % ﬁ
o

< E
x ~
:53-’\. wtra Info }'\' Imfo [4) }'\ W arning |}‘. Critical ‘W arning }.‘ Enor_;",' Suppressed )\' Flag_lf

EJMessage:DofE 2| 8= |
For Help, pre=s Fl Inis, Col 1 [ B 0 [ de AP [mm

Figure 3-4 The Verilog File of simple_counter.v
9. Save the file by choosing File > Save, pres€itig+ s, or by clicking the floppy disk icon.

10. Choose File > Create/Update > Create SymbasFibr Current File to convert the
simple_counter.v file to a Symbol File (.sym).Yoseuthis Symbol File to add the HDL code to

your BDF schematic.
14
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The Quartus Il software creates a Symbol File asplalys a message (segjure 3-5).

Quartus IL

\l\') Create Symbol File was succeszful

Figure 3-5 Create Symbol File was Successful
11. Click OK.
12. To add the simple_counter.v symbol to the @l design, click the my_first_fpga.bdf tab.
13. Choose Edit > Insert Symbol.
14. Double-click the Project directory to expand it
15. Select the newly created simple_counter syrmpalicking it's icon.

You can also double-click in a blank area of theFBD open the Symbol dialog box

Symbol X]
Libraries: il
B Poedt i

LEF counter_bus s

simple_counter

c:falkera/A Aquartuslibranies

[ Bepeatdnzert mode |

[ Imsertsymbol as block | s

r i

Megawizard Plugn Manager.. | ........................................................

k. LCancel

Figure 3-6 Adding the Symbol to the BDF

15
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16. Click OK.

17. Move the cursor to the BDF grid; the symbohga moves with the cursor. Click to place the
simple_counter symbol onto the BDF. You can mowelitock after placing it by simply clicking
and dragging it to where you want it and releasivegmouse button to place it. Segure 3-7.

& Quartuz II — E:/Hy dezign/my first fpga/my first fpga — my first fpga — [my firzt fpza. bdfs] E@@

ﬁ[ile Edit Yiew Froject Assigmnments Frocessing Teols HNindow Help = e
heEdg & i) 1m',_ﬂrst_f|3ga j
2GR T »rwr ("D b &b Qe
Prc?:lect L £l *@C simple_counter.v l @ my_fist_fpga.bdf*
,z Y_first_fpga.bdv @ s e e sy RGRIGY  MOe  nofy  SMGE  RALOION A AL RGN WDe  phofy  SMGN  ReLMNGE  ide b RGN MDY e an o
< | >
& L
— a1l
Tas - x el e
Flow: |Compilation :_J ﬁl e § o Slmple_ccunter
Tashd L
2 o I 4 ¢ o CLOCK_50 counter_out[31..0] fr—n aEA S g
B
Arials e e ... inst
".Netll:
T s g >
*| Type |}{essage -
i) In =
E.J
i j.J Info: Ended Full Comg tipn &t S8t Jun 12 15:17:03 2010 bl
% System [B]_fﬂ Froceszing [4] )\ Extra Info 1}\ Infa (4] )\ W arning }'\ Critical " arning
EIMessage: 0ofB ¥ I nrahion _J -
For Help, press Fi RN B Idie (Hum

Figure 3-7 Placing the simple_counter symbol

18. Press the Esc key or click an empty placeéhenschematic grid to cancel placing further
instances of this symbol.

19.  Save your project regularly.
Using Quartus Add a PLL Megafunction

Megafunctions, such as the ones available in thd,ld?e pre-designed modules that you can use in
FPGA designs. These Altera-provided megafunctiaesaptimized for speed, area, and device
family. You can increase

Efficiency by using a megafunction instead of wgtithe function yourself. Altera also provides

more complex functions, called MegaCore functiomsich you can evaluate for free but require a

license file for use in production designs. Thi®tial design uses a PLL clock source to drive a
16
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simple counter. A PLL uses the on-board oscillé2-115 Board is 50 MHz) to create a constant
clock frequency as the input to the counter. Tateréhe clock source, you will add a pre-built LPM
megafunction named ALTPLL.

1. Choose Edit > Insert Symbol or click Add Symbnolthe toolbar---

2. Click Megawizard Plug-in Manager. The MegaWizilug-In Manager appears (segure
3-8).

Nega¥izard Plug—In Nanager [page 11 |

The Megatwfizard Plug-ln M anager helps you create or modify
dezign files that contain custom wanationz of megafunchions.

\ YWhich action do you want to perfarm?
* Treate a new custom megafunchion wariation

(" Edit an existing custom megafunction wariation

" Copy an existing custorn megafunction yariation

Copyright [C] 1997-2010 Altera Corporation

Cancel | | MNewt > | |

Figure 3-8 Mega Wizard Plug-In Manager
3. Click Next.

4. In MegaWizard Plug-In Manager [page 2a], spetti/following selections (séegure 3-9):

a. Choose I/0O > ALTPLL.

b. Under Which device family will you be usin@hoose the Cyclone IV E for DE2-115
development board.

C. Under Which type of output file do you wamtcreate? Choose Verilog HDL.

d. Under What name do you want for the oufiga? Type pll at the end of the already
created directory name.

e. Click Next.

17
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Nega¥Wizard Plug—In Nanager [page 2al @

Which megafunction would you like to cuztomize'? Wwhich device family will you be ||:}..3|.;.ne IV E ﬂ
. . Lzing?
Select a megafunction from the lisk below
& 110 = Ww'hich type of output file do vou want ko create?
' © AHDL
~
ALTASMI_PaRaLLEL - EH'_:'L
ALTCLKCTRL * Verilog HDL
ALTDDIO_BIDIR .
- ¥
ALTDDIO_IN What name do you want far the outpuk file’ Browse. ..
ALTDODIO_QUT |E:HM_','_EIEsign"um_l,l_first_fpga"mpll.v

ALTDO

ALTDUS [ Beturn to this page for another create operation

Maote: To compile a project succezsfully in the Quartuz | zoftvare,
wour design files must be in the project directory, in the global uzer
ALTIOBUF libraries zpecified in the Options dialag bax [Taols menu), or a uzer
library specified in the Lzer Libranes page of the Settingz dialog
ALTLYDS box [Azsignments menu).
ALTMEMPHY

Your current uzer library directones are:

FRALTPLL Froject User Libraries:
ALTPLL_RECOMFIG .

.triple_speed_ethernet-librar_l,l'\.
ALTREMOTE_UPDATE megafunctionsh

w30 _fpoa_bup_maxi_interface,

+-f@&d Interfaces b

Cancel | < Back | Hest » | |

Figure 3-9 MegaWizard Plug-In Manager [page 2a] Selections

5. In the MegaWizard Plug-In Manager [page 3 of wjdow, make the following selections
(seeFigure 3-10).

a. Confirm that the Currently selected device fgnmobtion shows the device family that
corresponds to the development board you are using.

b. The device speed grade choose 8 for DE2-115.
c. Setthe frequency of the inclockO input 50 MHz.

d. Click Next.

18
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NegaWizard Plug—In Manager [page 3

of 14]
Parameter |
Settings Al e o
Bandwidth/55 Clock switchover
Currently selected device family: ) = o
pll :
inckd |

W Match project/default
Able toimplement the reguested PLL

-General -

Which device speed grade will you be using?

What is the frequency of the inclockd input?

~PLL type

‘wihich PLL type will you be using?

# Select the PLL type automatically
Operation mode
Hiww will the PLL outputs be generated?
) Use the feedback path inside the PLL
! In Mormal Mode

i In Source-Synchronous Compensation Mode
¢ In Zero Delay Buffer Mode

) With no compensation

Which output clock will be compensated for? |rcu |

| Cancel || < Back. || Mext > || Finish |

Figure 3-10 MegaWizard Plug-In Manager [page 3 of 14] Selections

6.

Turn off all options on MegaWizard page 4. As yorntthem off, pins disappear from the PLL
block’s graphical preview. Séegure 3-11 for an example.
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of 14]

Documentation

Bandwidth /55 Clodk switchower

Able to implement the requested PLL

- Optional inputs

] Create an ‘areset’ input to asynchronously reset the PLL

[ Create an 'pfdena’ input to selectively enable the phase/freq. detectar

Lock output
1 Create 'jocked' output
["] Enable self-reset on loss of lock

~Advanced PLL parameters
Using these parameters is recommended for advanced users only

[ Create output file{s) using the 'Advanced’ PLL parameters
- Configurations with output clock{s) that use cascade counters are not supported

| Cancel || < Back || Hext > || Finish |

Figure 3-11 MegaWizard Plug-In Manager [page 4 of 14] Selections

7. Click Next three times.

8. At the top of the wizard, click the tab 3. Out@locks to jump to the Output Clocks > clk cO

page

Clock Division Settings  input 16iQure 3-12).
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inclk0

cl - Corg/External Qutput Clock
Able to implemeant the requested PLL

1 Use this dock
i~ Clock Tap Settings

) Enter output dock frequency:

®) Enter output dock parameters:

Clock multiplication factor
Clock division factor

Clock phase shift

Phase shift step resolution{ps)

Clock duty cyde (%)

More Details ==

Requested settings Actual settings

- 5.000000

§1o| % 10

oo [ [aeo

ed ©l €2 3 4

| Cancel ” < Back ” Mext = || Finish |

Figure 3-12 MegaWizard Plug-In Manager [page 8 of 14] Selections

9. Click Finish.

10. The wizard displays a summary of the fileg@ates (sekigure 3-13). Click Finish again.

ter
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Turn on the files you wish to generate. A gray checkmark indicates a file thatis

automatically generated, and a red checkmark indicates an optional file, Click
Finish to generate the selected files. The state of each checkbox is maintained in
subsequent Megalizard Plug-In Manager sessions.

inclk0

The MegaWWizard Plug-In Manager creates the selected files in the following
directory:

E:\My_designimy_first fpaal,

File I [rescription ]
[ pll.a W ariation file

[ pll.ppf PinPlanner ports PPF file

[ pllinc AHDL Include file

O pl.cmp WHOL component declaration file

[ pll.bsf Guartuz 1l zymbil file

O pll_inzt.» |nztantiation template file

1 pll_bb.v Werilog HDL black-box file

‘ Cancel || < Back ‘ E _

Figure 3-13 Wizard-Created Files

The Symbol window opens, showing the newly cre&ked megafunction. Seeigure 3-14.

ter
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Symabol

Libraries:

E & Project

@] simple_counter

£/
23 c/altera/91  quartusibranes?

£ [ »
Marne;
i -]

v Bepeat-ngert mode

[ Inzert syrmbol as block
-

| Megawiizard Plug-ln Manager...

SRR pll SRR
S [inclko N c0f i
S SymemeVE ] lliiiiin

Ok

Cancel

11. Click OK and place the pll symbol onto the B@FRhe left of the simple_counter symbol. You
can move the symbols around by holding down theentefuse button, helping you ensure that they

line up properly. Sekigure 3-15.

ter

Figure 3-14 PLL Symbol
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4% Quartus II - E:/Ny design/my first fpga/my first fpga — my first fpga - [my first fpga.bdfs]

%Eile Edit ¥iew Froject Assignments TFrocessing Tools Hindow Help

AR 2ERC D rVs 00 RS % ae

0O = H ﬁ % e @ L) |m;_ﬂrst_fpga
R aear == a@° simple_counter ] @ my_first_fpga.bdf* I
3 Files & |
@ hy_first fpes bd [
abd gimple counter. v =
ER A
< T
o0
I =1 = pll
Tasks - x ==l|. = =
Flow: [Compilation = e . Esimple_ccunter
T - |incko ] &Bif 5. v s
a5 EB Y inclk( frequency: 50.000 MHz et one s X CLOCK 50 counter_out[31..0] e
| Operation Mode: Mormal H
Clk |Ratio |[Ph (dg) | DC (%)
oo c0 [ 110 | 000 | 5000 | inst
SN .-
: instd Cyclone IV E L . |
: . m
< < *
= Sl
I i o
::._—‘f. System [B]_[{‘ Processing [4] )\' Extralnfa )\' Info (4] )\'_W’aming )\‘ Critical Warning ,\ Error }\ Suppreszed )\' Flag f

e
i |Message Oof &

For Help, pressz Fl

2| ¥

| Idle (Hm

12. Move the mouse so that the cursor (alsoat#ie selection tool) is over the pll symbol’s cO

Figure 3-15 Place the PLL Symbol

output pin. The orthogonal node tool (cross-haioniappears.

13.  Click and drag a bus line from the cO outputhe simple_counter clock input. This action

ties the pll output to the simple_counter inpue(Seyure 3-16).

inclkO

pll
. ... [simple_counter i
inclkd frequency: 50.000 MHz : CLOCK_50 counter_out[31..0] =
Operation Maode: Mormal '
Clk |Ratio |Ph {dg}| DC (%) ,
c0 | /10| 0.00 | 50.00 S inst L
CydloneNE | lilllllliloiiniiiiiiiiiiiiiioiin

inst4

Figure 3-16 Draw a Bus Line connect pll cO port to simple_counter CLOCK_50 port

14.  Add an input pin and an output bus withftl®wing steps:

ter
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a. Choose Edit > Insert Symbol.
b. Under Libraries, select quartus/libraries > ptires > pin >input. Se€igure 3-17
c. Click OK

If you need more room to place symbols, you canthe vertical and horizontal scroll bars at the
edges of the BDF window to view more drawing space.

Symbol x|

Librarigs:

23 Project | [T
G .IJ ........................................................

E B C:ll.lalterall.'g‘l .-"quartus;"ﬁbraries.-" ........................................................

|=:| megafunchionz | |-

I'il athers
FHES primitives | |

f:lbuffer ........................................................
HZ3 logic i
FHED ather i
EHE pin L
E?---ﬂ'hidir ........................................................

Y N B I {pin_name i DD EN
'tl StDragE ................. -~ 2

< 1

Mame: oo

input Bl

[ Bepeatdnzert mode |

|_ ........................................................

r i

Megawizard Plugn Manager.. | ........................................................

k. LCancel

Figure 3-17 Input pin symbol
d. Place the new pin onto the BDF so that it i<kdog the input to the pll symbol.

e. Use the mouse to click and drag the new inputt@ithe left; notice that the ports remain
connected as shown fgure 3-18.

pll
o Paimple_counter
- g name P 1 inelkD | freouency: 50,000 MHz ey - CLOCK_S0  counter_out[21.0] 9
PP Operation Mode: Normal
[cik_[Ratio [ Pn (dg) [ D (%)] .
BN 5
inzts Cyclone W E
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Figure 3-18 Connecting the PLL symbol and Input port

f.  Change the pin name by double-clicking pin_name typing CLOCK 50 (sefeigure 3-19).
This name correlates to the oscillator clock teatannected to the FPGA.

g. Using the Orthogonal Bus tool, draw a bus linanected on one side to the simple_counter
output port, and leave the other end unconnecteabatit 4 to 8 grid spaces to the right of the
simple_counter.

Pin Properties ﬁ'

Feneral lF-:-rmat ]

To create multiple pinzg. enter a name in AHDL buz natation [for example,
"name[3..0]"], or enter a comma-zeparated lizt of names.

Pin name(s]: |I:LEI CK_50

Default value: |ﬁ.,.f|:|: j

wE | B

Figure 3-19 Change the input port name

h. Right-click the new output bus line and choosmpErties.

i.  Using the Orthogonal Bus tool, draw a bus lioarected on one side to the simple_counter
output port, and leave the other end unconnecteabatit 6 to 8 grid spaces to the right of the
simple_counter.

J.  Type counter [31..0] as the bus name (Segre 3-20). The notation [X ..Y] is the Quartus I
method for specifying the bus width in BDF schergtivhere X is the most significant bit (MSB)
and Y is the least significant bit (LSB).

k. Click OK.Figure 3-21 shows the BDF.

26
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Buz Properties [')_<

General lF-:-nt ] Format ]

Hame: |-:|:|unter[31 i)

[ Hide name in block design file

fifE Rl

Figure 3-20 Change the output BUS name

B File Edit View Projsct Assigments Processing Tools Hindow Help

DSsHg & %

[ v o |[my_first_poa W rEREG D e r @ 8 A e
PrgctNavigator - - % a@-c S ehuery ] @ my_first_fpga.bdf* }
Filaz ~ E 1

,....;; Ez first figa.bd._

i simple_counter. v

ERE pllgip v

inclkl

El- B Part:

gl @ 2
&/\ System (8) £ Processing (4]}, Ewtralofo }, Info (4] J, Waming J\_Ciiical'waming_}, Evar J, Suppressed , Flag |
EjMessage: OofE J ﬂ I St __J =t
For Help, press Fi .Jlﬂ.:\ ) | Idie I |
Figure 3-21 BDF
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3.2 Add a Multiplexer

This design uses a multiplexer to route the singmeanter output to the LED pins on the DE2-115
development board. You will use the MegaWizard RlugManager to add the multiplexer,
Ipm_mux. The design multiplexes two variations e tounter bus to four LEDs on the DE2-115
development board.

1. Choose Edit > Insert Symbol.

2. Click Megawizard Plug-in Manager.

3. Click Next.

4. Choose Installed Plug-Ins > Gates > LPM_MUX.

5. Choose the device family that corresponds todéngce on the development board you are
using, choose Verilog HDL as the output file typed name the output file counter_bus_mux.v (see
Figure 3-22).

6. Click Next.

28
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7.

8.

Nega¥izard Plug—In Nanager [page Zal

YWhich megafunction would you like to customize?

Select a megafunction from the lizt below

=-{m] Inztalled Plug-Ins
Altera SOPC Builder

+-@ Arithmetic

+- @@ Communications

+ g D5P

- Gates
] LPM_aND
4 LPM_BUSTRI
LPM_CLSHIFT
LPM_COMSTAMT
LPM_DECODE
LPh_IMY
LPt_k 1
LPM_0OR
LPM_=<0R

+-mg /0
+-@@ Interfaces
+- @@ JTAG-acceszible Extenzions
+ @@ Memaory Compiler
+ @ Storage
+ @ P MegaStore

Wwhhich device family will you be

Cyclone W E -
uzing? Y J

whhich type of output file do pou want to create?
" AHDL

" WHDL

* “Yerlog HOL

wihat name do you want far the output file?

Browse. ..

|E:'\M yw_deszign'my_first_fpgahcounter_bus_mos v

[ Return ta this page for ancther create operation

Mate: To compile a project successfully in the Quartusz || zofbware,
your dezign files must be in the project directory, in the global uzer
libranes specified in the Options dialog box [Toaolz menu], or a user
librany specified in the ger Libraries page of the Settings dialog
bow [Aezignments menu).

Your current ugzer library directonies are:

Project User Libranies:

A

triple_zpeed_ethernet-libranh,
megafunctions'
dqw30_fpga_bup_maxi_interface’

Cancel | ¢ Back | MHewt > | |

Figure 3-22 Selecting Ipm_mux

Under How many ‘data’ inputs do you want? Seleictputs (default).

Under How ‘wide’ should the data input and résuitput be? Select 4 (sEeyure 3-23).

ter
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Plug—In Nanager — LPE NUX [page 3 of 5] |Z”E|E|

LPM_MUX

| About ” Documentation

Currently selected device family: v

data1x]3..0] M Match project/default

datalx]3..

Haow mary 'data’ inputs do vou want?
Haow wide zhould the 'data’ input and .
the 'rezult’ output buses be’? bits
Do you want to pipeline the multiplexer?

i® Nao
i Yes, I want an output latency of v

Rezource Ugage

1 lpm_mux

| Cancel ” < Back || [ext = ” Einish |

Figure 3-23 Ipm_mux settings
9. Click Next.

10. Click Finish twice. The Symbol window appeasgfigure 3-24 for an example).
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Libraries: L

M S Project e
=E e S D
& _ci/altera/S Aquattus/ibraties! || oo

|=:| megafunchion: | | -

MED others |
HEr primitives e
Gbuﬂ:er ........................................................
FET logic e

T

o O
- bidi croiciocoeeee b counter_bus_mux
£ output A £+ - § A A
HE storage Conioono s idataluf3 o]

................... st

< 2] 1 S

Mame: e

|CDUHtEf_bU3_|TIUH Ll

[ Bepeatinzertmode | o

r D

[ Launch Megawizard Flugdn | 00000 0o n

| Megatizard Plug-In Manager... | Ll

ok LCancel

Figure 3-24 Ipm_mux Symbol

11. Click OK

12. Place the counter_bus_mux symbol below theiegisymbols on the BDF. Séegure 3-25.
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- linclko el Fremyan e 55000 ke cbyg - - [

counter_bus_mux

- idatalx[2.01

. eaylT OG-
- idatalx[3..0] STHERL :
el

Figure 3-25 Place the Ipm_mux symbol
13. Add input buses and output pins to the coubtes_mux symbol as follows:
a. Using the Orthogonal Bus tool, draw bus linestithe datalx[3..0] and data0x[3..0]
Input ports to about 8 to 12 grid spaces to theoketounter_bus_mux.

b. Draw a bus line from the result [3..0] outputtpo about 4 to 8 grid spaces to the right of
counter_bus_mux.

c. Right-click the bus line connected to datal®3and choose Properties.
d. Name the bus counter[26..23], which selects tndge counter output bits to connect to
the four bits of the datalx input.

Because the input busses to counter_bus _mux havesaime names as the output bus from
simple_counter, (counter[x .. y]) the Quartus litaare knows to connect these busses.

e. Click OK.
f.  Right-click the bus line connected to dataOX]Band choose Properties.

g. Name the bus counter [24..21], which selecty tmdse counter output bits to connect to the
four bits of the datalx input.

h. Click OK.Figure 3-26 shows the renamed buses.
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counter26. 23] gatatyi3 0

counter_bus_mux :

resultf3.0]i resulfi3.01 -

Figure 3-26 Renamed counter_bus_mux Bus Lines

If you have not done so already, save your prdjecbefore continuing.

14. Choose Edit > Insert Symbol.

15. Under Libraries, double-click quartus/librafiegprimitives > pin > output (s€egure 3-27).

Syabol

Librarigs:

23 Project
o

HET others

FHEr primitives
FHED buffer
HE logic
FET other
FHE pin
L LED b
POREL input

B storage

=] @ c:falkera/A1 Aquartuslibrarnies /!
FE1 megafunctions

[ Bepeatinzert mode
—
—

£ >
M arre:
||:|ut|:|ut J

Megawizard Plug-In Manager... |

Q.

LCancel

16. Click OK.

Figure 3-27 choose an output pin
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17. Place this output pin so that it connects godbunter _bus_mux result [3..0] bus output line.

18. Rename the output pin as LEDR [3..0] as desdrib steps 13 c and d. (Séegure 3-28).

Eclata'lrx;ﬁ 01l
+ - Ldata0x]3_0]]

| nsts.
Figure 328 Rename the output pin
19. Attach an input pin to the multiplexer selégelusing an input pin:
a. Choose Edit > Insert Symbol.
b. Under Libraries, double-click quartus/librariegprimitives > pin > input.
c. Click OK.
20. Place this input pin below counter_bus_mux.
21. Connect the input pin to the counter_bus_mupise

22. Rename the input pin as KEY [0] (s€gure 3-29).

EUSER E = inclkd

counter_bus_muzx

2 datalx[2..0]
% datax(2. 0]

resylt[3.0]i==

Figure 3-29 Adding the KEY [0] Input Pin
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You have finished adding symbols to your desigru ¥an add notes or information to the project
as text using the Text tool on the toolbar (indddatvith the A symbol). For example, you can add
the label “OFF = SLOW, ON = FAST” to the KEY [0]pnt pin and add a project description, such
as “My First FPGA Project.”

3.3 Assign the Pins

In this section, you will make pin assignments. @def making pin assignments, perform the
following steps:

1. Choose Processing > Start > Start Analysis &bv&idation in preparation for assigning pin
locations.

2. Click OK in the message window that appears aftalysis and elaboration completes.

To make pin assignments that correlate to the KEf¥ahd CLOCK_50 input pins and LEDR([3..0]
output pin, perform the following steps:

1. Choose Assignments > Pins, which opens the PimBtaa spreadsheet-like table of specific
pin assignments. The Pin Planner shows the desgnfsns. Seéigure 3-30

% Quartus II — E:/Ny_design/my_first_fpza/my _first_fpga — my first_fpga — [Pin Planner]

File Edit Yiew PFroceszing Tools Hindow
* MNamed: [§ - | w3l Edit 3| | Fiter: | Fing: all ~|
Mode Mame Direction Location 10 Bank VREF Group 1/0 Standard Reserved

1 B CLOCK_50 Input 2.5V (default)
2 = KEY[D] Input 2,5V {default)
3 ¢  LEDR[3] Qutput 2.5V (default)
4 LF LEDR[Z] Qutput 2.5V (default)
5 ¥  LEDR[1] Qutput 2.5V (default)
[ ¥  LEDR[D] Qutput 2.5V (default)
7 <<new node >

For Help, pres: Fl CaF HIM

Figure 3-30 Pin Planner Example

2. In the Location column next to each of the six nodenes, add the coordinates (pin numbers)
as shown imable 3-1 for the actual values to use with your DE2-115rboa

Table 3-1 Pin Information Setting

Pin Name FPGA Pin Location
KEY][0] M23
LEDR][3] F21
LEDR[2] E19
LEDR [1] F19
LEDR [0] G19
35
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CLOCK_50 Y2

Double-click in the Location column for any of thix pins to open a drop-down list and type the
location shown in the table alternatively, you satect the pin from a drop-down list. For example,
if you type F1 and press the Enter key, the Qudrtssftware fills in the full PIN_F1 location name
for you. The software also keeps track of corredpanFPGA data such as the I/O bank and VREF
Group. Each bank has a distinct color, which cgess to the top-view wire bond drawing in the
upper right window. Sekigure 3-31.

% Quartus II — E:/Ny desizn/my first fpza/my first fpgza — my first fpga — [Pin Planmer] r._JE|§|
File Edit View Processing Tools HYindow
* Named: [§ v | «s Edt 3| | [PIN_G13 Fiter. |Ping: al ~|
Mode Name Direction Location /0 Bank VREF Group 10 Standard

1 I CLOCK_50 Input PIM_Y2 2 B2_MNO 2.5V (default)
2 B KEY[O] Input PIN_M23 & B6_N2 2.5V {default)
3 i  LEDR[3] Output PIN_F21 7 B7_ND 2.5V {default)
4 & LEDR[Z] Output PIN_E19 7 B7_NO 2.5 {default)
5 ¥  LEDR[1] Output PIN_F19 7 B7_NOD 2.5V {default)
5 & LEDR[]] Output 7 B7_N2 2.5 {default)
7 <<new node =

For Help, press Fl CAP HIM

Figure 3-31 Completed Pin Planning Example

Now, you are finished creating your Quartus Il dasi

3.4 Create a Default TimeQuest SDC File

Timing settings are critically important for a sassful design. For this tutorial you will create a
basic Synopsys Design Constraints File (.sdc)tti@Quartus Il TimeQuest Timing Analyzer uses
during design compilation. For more complex desigysu will need to consider the timing
requirements more carefully.

To create an SDC, perform the following steps:

1. Open the TimeQuest Timing Analyzer by choosiagl3 > TimeQuest Timing Analyzer.
2. Choose File > New SDC file. The SDC editor opens

3. Type the following code into the editor:

create_clock -period 20.000 -name CLOCK_50

derive_pll_clocks
36
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derive_clock_uncertainty

4. Save this file as my_first_fpga.sdc (Segure 3-32)

4! Quartus II — E:/Ny design/my first fpga/my first fpga — my first fpga — [my first fpga.sdc]

#F File Edit View Project Assigmments Frocessing Tools Window Help

DEEH@ S| " =@ o [yt g e @LE D > TRt Q@ G0
Project Navigator - 3
S e & 3@0 simple_counter.y I @ my_first_fpga.bdf ] @ Compilation Report - Flow Summary ] a@ my_first_fpga_sdc ]
24 Files
;ﬁ my_first_fpga bAf @ ; at _S_:c-{ tp‘E:'_cd 20.000 -name CLOCK 50
i8¢ simple_counter. v " £ 5 = A CLOGRD
4 3 erive clo UNCETTainty
B sl aip i P : ve_clock a ¥
dh g1l w
counter_bus_moc qip *;E €§
jb‘ counter bus_mux. v S5 .
20 fny_first fpga. sde 4%
v
* %
Hlararch_l,lJ B FI|BSJ dF Design Units I @ =
Tasks . x @
Flow: |Compilation b
67 o
268
Tack [ | s
E]
; 4 Synthesi =
T Bdit Settings
B View Report
- hnalysis= & Elab.
- Partition Merge
Fetlist Viewers
&3 RTL Viewer
Q State Machir
B8 Tacknalaer Y
£ < >
= Type | Mezaage s
j/ Info: Quartus II Full Compilation was succeasful. T .errora, 32 warnings
¥
)% *
% Syztem [8] }\_Pmcessing [131]_/{ Eutra Info )\ Inf [113] )\ Warning [14] )\ Critical Waming (4] )\Error )\ Supprezzed [B] )\ Flag,f
@

ElMessaga 0 of 343 JJl o _J Logalz

For Help, press Fl Ing Coll [l B & | Idie ICAP M

Figure 3-32 Default SDC

Naming the SDC with the same name as the top-fdeetxcept for the .sdc extension causes the

Quartus Il software to using this timing analysie utomatically by default. If you used another
name, you would need to add the SDC to the assigtsnfiée list.
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Chapter 4

Compile and Verify Your Design

After creating your design you must compile it. Golation converts the design into a bitstream
that can be downloaded into the FPGA. The most rapb output of compilation is an SRAM
Object File (.sof), which you use to program theide The software also generates other report
files that provide information about your code tasoimpiles.

4.1 Compile Your Design

If you want to store .SOF in memory device (suclilash or EEPROMS), you must first convert
the SOF to a file type specifically for the targeteemory device.

Now that you have created a complete Quartus ljeptaand entered all assignments, you can
compile the design.

In the Processing menu, choose Start Compilatiarick the Play button on the toolbar.
If you are asked to save changes to your BDF, desk

While compiling your design, the Quartus Il softergprovides useful information about the
compilation (seé-igure 4-1).
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4 Quartus II — E:/Ny_dezign/my first fpga/my first fpga — my first fpga — [Compilation Report — Flow Summary] g@@
=

@ File Edit Yiew Project Assigmments Frocessing Tools Windew Help - 5
i = - M= R 2 | oo || { thc Clgeeed | Bl o h |0 Al

Praj Vi - . . T "

Folcet Mavigator = @ my_first_fpoa bdf ] 3@0 simple_counter.v ] @ Compilation Report - Fl... | 3@’ my_first_fpga. sdc ]

Entity -~ —
&y Cyclome IV E: EP4CE11SF2908 | — el pee- sl @

é Legal Hotice

B ny_first_fpza gl a] - SBFE Flow Summary
_<_ > @% Flow Settings
dyHierarchy | B Files | 87 Design Units | - E3EE Flow Non-Default Globsl

@% Flow Elapzed Time

s +x @% Flow 05 Summary

Tow: [Conprlation | | ~&EB Flow Log
o

# & Analysis & Synthesis

Tazk &
Flow Status In progress — Sat Apr 17 21:42:19 2010
Huartus IT Version 9.1 Build 350 03/24/2010 SF 2 5T Full Version
Rewizion Hame my_first_fpga

Top~lewel Entity Name my_first_fpga
Family Cxclone IV E

£ 3 |z >
| Twype ~
\i') PLlL elTtpll auto generated
é.J
Hd displayed belo -
[0 3 I b v
P Bl | >
& _ System [18] }\_Plo_c;egsir_i_g_ _[24]_[;{‘_ Ewtra Info )\ Infa (24) ;"'. Warring )\ Critical W arning )". Error )". Suppressed ;f\ Flag_,“r
i

EiMessage:DofSS _J _‘J | acati _J (WelsEIT
For Help, press Fl LB 0 [HE M 00:00:04 nm

Figure 4-1 Compilation Message for project

When compilation is complete, the Quartus Il sofevdisplays a message. Click OK to close the
message box.

The Quartus Il Messages window displays many messdgring compilation. It should not display
any critical warnings; it may display a few warrsripat indicate that the device timing information
is preliminary or that some parameters on the if@ psed for the LEDs were not set. The software
provides the compilation results in the CompilatiReport tab as shown gure 4-2.
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Flow Status Successful - Wed Jul O7 20:15:57 2010
Huartus IT Ver=zion 9.1 Build 350 03/24/2010 SF 2 5T Full Yersion
Revizion Hame my_first_fpgza
Top—lewel Entity Hame my_first_fpgza
Family Cyclone IV E
Device EP4CE115F29CT
Timing Models Preliminary
Met timing requirements Hin
Total lozic elements 3 114,480 <1 %)
Total combinational functioms 31 f 114,480 [ <1 % )
Dedicated logic registers ET 4 114,480 (<1 %)
Total registers 27
Total pins B 529 (1 %)
Total wirtual pins 0
Total memory bits 0/ 3,931,312 (0% )
Embedded Multiplier 9-bit elementz= 0 f 532 (0 % )
Total PLL= 174 025%)

Figure 4-2 Compilation Report Example

4.2 Program the FPGA Device

After compiling and verifying your design you aeady to program the FPGA on the development
board. You download the SOF you just created inloRPGA using the USB-Blaster circuitry on
the board. Set up your hardware for programminggusie following steps:

a) Connect the power supply cable to your boardtardpower outlet.

b) For the DE2-115 board, connect the USB-Blasteiyded in your development kit) to J9 and
the USB cable to the USB-Blaster. Connect the athdrof the USB cable to the host computer.

Refer to the getting started user guide for deddistructions on how to connect the cables.
c) Turn the DE2-115 board on using the on/off skitc
Program the FPGA using the following steps.

1. Choose Tools > Programmer. The Programmer wirmfuems. Se€igure 4-3.
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Wl Quartus IT - E:/Ny_design/my_first fpea/my first_fpga — my_first fpea - [my_first fpea. cdf] B=E

File Edit Fracessing Teols Hindow

é;; Hardware Setup...| | USEB-Blaster [USB-0] Mode: |JTAG ﬂ Progress: ]

[ Enable realtirme |SP ta allaw backaround pragrarnening [for WA 1| devices)

i

Blank-

Werify ‘ Check ‘ Examine Sl

Program/ o | Erase

. 15
W Start File Configure CLA
Ty frsl_ipga sof EFACETIEFZS TOGEEECS  FFFFFFFF O 0O 0 O O C

b autoDetect_|
XDz |
B8 change Fie.. |
Ebsoverie. |
o A
Yoo |

Device ‘ Checksum ‘ Usercode ‘

|
W

For Help, press Fl

Figure 4-3 Programmer Window

2. Click Hardware Setup.

3. Ifitis not already turned on, turn on the UBBster [USB-0] option under currently selected
hardware. SeEigure 4-4.

Hardware S5etup [5_<|

Hardware Settings l_]'T_ﬁlG Settings]

Select a programming hardware setup o use when programming devices. This programming
hardware zetup applies anly to the current programmer windaw,

Currently selected hardvware: IISE-Blaster [USE-0] ﬂ
&vailable hardware itermns: I_IEIEI-I:I]
Hardware Server Pt Add Hardware. .

I15E-Elaster Local 15E-0 |

Figure 4-4 Hardware Setting

4. Click Close.
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5. If the file name in the Programmer does not showfirst_fpga.sof, click Add File.

6. Select the my_first_fpga.sof file from the pijdirectory (seéigure 4-5).

Ul Quartus IT - E:/Ny_design/my _first_fpga/my first_fpga — my first_fpza — [my_first_fpga. cdf] r]Elﬁl

File Edit PFrocesz=zing Tools Window

éa Hardware Setup... USB-Blaster [USB-0] Mode: |JTAG ﬂ Progress:

[ Emnable reaktine ISP ta allow back ground programming (for M2 1| devices]

i Start File: Device Checksum Usercode Eroon%irgam; Verify E:,?ggk E xamine SEEE:”GI Eraze
my_first_fpga.sof EP4CE115F29 00578EDF FFFFFFEF

ﬂ]ﬂ Auto Detect

. Delete

(2 Add File...

i Change File...

(2 Add Device...

For Help, press Fi nm

Figure 4-5 Downloading Complete

Congratulations, you have created, compiled, armbrammed your first FPGA design! The
compiled SRAM Obiject File (.sof) is loaded onto tRBGA on the development board and the
design should be running.

4.3 Verify The Hardware

When you verify the design in hardware, you obsémeeruntime behavior of the FPGA hardware
design and ensure that it is functioning approplyat

Verify the design by performing the following steps

1. Observe that the four development board LEDsappo be advancing slowly in a binary
count pattern, which is driven by the simple_coubits [26..23].

The LEDs are active low, therefore, when countiagibs all LEDs are turned on (the 0000 state).

2. Press and hold KEY [0] on the development b@ard observe that the LEDs advance more
quickly. Pressing this KEY causes the design totiplak using the faster advancing part of the
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counter (bits [24..21]).

3. If other LEDs emit faintness light, Choose Assigents > Device. Click Device and Options.
SeeFigure 4-6.

Settingzs — my first fpga

Categon:
Libraries ~
- Device ;
[=1- Operating Settings and Conditions Select the family and device you want to target for compilation.

i Waltage

i - Temperature [~ Device Family - Show in Aevalable devices' list
[=I- Compilation Process Settings ;
H ; F anmily: Fackage:

- Early Timing Estimate Lamy IEyc:I-:-ne I E Li il Any #
¢ - Incremental Compilation ) Pl eatnE iy =
: H 3 4 .. 7 [Dewices Al = =
: - Phyzical Synthesiz Dptimization | _J

= ED& Tool Settings Speed grade: |Any -
o Design Entry/Synthesis i~ Target device | W Show advanced devices
- Sirnulation (7 Auto device selected by the Fitter I o SrdBanycompatble:anl

i Timing Analyziz

; X & Specific device selected in 'Available devices' list
- Formal Wenfication

- Physical Synthesis . = Other e Device and Pin Options... I
. Board-Level )
=- Analyziz & Synthesiz Settings Ayailable devices:
;--VHI;JLInput M ame | Corew. | LEs | Userl/.. | Memor.. | Embed... | PLL ]
-~ Verilog HDL Input ' EP4CE115F23CT 1.2 114480 281 /FINZ 5L 4
- Default Parameters EP4CE115F23C8 1.2 114480 231 3931312 532 4
- Fitter Settings EP4CE115F23CEL 1.0 114480 281 3931312 532 4
=1 Timing Analysis §ettings EF4CET15F230a0 1.0V 114480 281 3981312 532 4
- TimeQuest Timing Analyzer EP4CE115F23I7 1. 114480 281 3981312 532 4
= Classic Timing Analyzer 5 etting . 114480 28 3981 31 532
= asssiet Tininig Snaljaet by EPACE115F29C8 12¢ 114480 529 3981312 532 4
- Assembler EP4CE115F29CEL 1.0V 114480 529 /A2 5I2 4 2
5 DESIgn ASSIStant CoArc11REC2aal 1 114400 [=4pin} 2001 317 E27 4 —
i ~SignalT ap || Logic Analyzer 3 o ! 2

- Logic Analyzer Interface
=1+ Sirnulatar Settings
- Simulation Yerfication Miaration Devices... HardCan _,j
L Simulation Output Files
- PowerPlay Power &nalyzer Setting
55N Analyzer ot

" - | @ oK | 'cance||

i~ Migration compatibility -

3

[ migration devices selected ¥ Limit DSP & Fah to HardCopy devic

Figure 4-6 Device and Options

Choose unused pins. Reserve all unused pins: Chio@#es input tri-stated option. SEejure 4-7.
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Dewice and PFin Options @

Imal-Furpoze Fins ] Yoltagze ] Fin Placement ]
Error Detection CRC ] Capacitive Loading ] Board Trace Model ] I/0 Timing]
General ] Configuration ] Frogramming Fileaes { lUnmzed Pinz !

Specify device-wide options for reserving all unuzed ping on the device, To reserve
individual dual-ourooze confiauration ping. oo to the Dual-Puroose Ping tab. To
reserve other ping individually, use the Aszignment Editor.

Feserve all unused ping: | &3 input tri-stated ﬂ

Dezcription:

Reszerves all unuszed pinz on the target device in one of B states: as inputs that are
tri-stated, az outputs that drive ground, as outputs that drive an unspecified zignal,
az input tri-ztated with bus-hold, or az input tri-stated with weak pull-up.

Figure 4-7 Setting unused pins

Click twice OK.

4. In the Processing menu, choose Start Compilatifter the compile, Choose Tools >
Programmer. Select the my_first_fpga.sof file frime project directory. Click Start. At this time
you could find the other LEDs are unlighted.
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Chapter 5
DEZ2-115 System Builder

5.1 Headquarter & Branches

e Tel :+886-3-5508800

 Fax : +886-3-5502860

e Add: No.356, Sec. 1, Fusing E. Rd., JhuBei City , HsinClounty Taiwan
302-64

* Email : sales@terasic.com / support@terasic.com

45
Ierm www.terasic.com
www.tel

rasic.com.




